Concourse Financial Software

Concourse Financial Software Suite Receives PCI PA-DSS Version 3.2 Validation

pci-pa-dss-logoBHMI has received PCI PA-DSS Version 3.2 validation for all modules within the Concourse Financial Software Suite. This includes Concourse – Core, Concourse – Extended Settlement, Concourse – Reconciliation, Concourse – Fees & Commissions, and Concourse – Disputes.

The goal of PA-DSS is to ensure that software vendors are developing secure payment applications that do not store prohibited cardholder data. PA-DSS applies to applications that store, process, or transmit cardholder data as part of authorization or settlement. These applications must be aligned with the payment application security requirements and audit procedures defined by the PCI Security Standards Council to ensure that any customer using the payment application remains PCI DSS compliant when the payment application is implemented.

As the creator of back office payments processing software, BHMI worked with a third-party Payment Application-Qualified Security Assessor (PA-QSA) to validate that the Concourse Financial Software Suite complies with PA-DSS Version 3.2 standards.  Upon a thorough audit of all modules within the Concourse Financial Software Suite, a formal PA-DSS Version 3.2 validation has been provided and is listed on the PCI Security Standards Council Web Site under Baldwin Hackett & Meeks, Inc.

Comments

Leave a Reply

Your email address will not be published. Required fields are marked *